BenV's notes

Gnome kankerbende

by on Jul.28, 2009, under Software

RAaaah, I’d be soo happy if everyone collectively decided to drop this piece of twine into a big fire…. blegh.

So I want gmpc…. so I build libmpd, no issues at all. Libsoup is next, which somehow wants gnome-common or something because of CVS requirements or whatever its problem is today. So I try configure –without-gnome and it breaks. Ok, that’s obviously the fault of libsoup, however, I decide to go through with the gnome garbage once more and make the fatal mistake of trying to build those things.

gnome-common goes without much issues. (oh, needless to say I always take the last version I find, 2.26 today I think). Next it seems to need libproxy, also no issues. Orbit(ch)-2 ย is next, also goes without hassle. So far so good ๐Ÿ™‚

But then, GConf. That monstrosity requires 12837189347 other things, but worse: THEY NEED TO BE RECENT! (of course the simple solution would be to downgrade it, but that’s for later). So we start… ” No package ‘polkit-dbus’ found”. Great. So I get Policykit, 0.93. But nooo, that needs eggdbus. FINE! So eggdbus it is (0.5), but nooo, that needs a more recent version of $something. Version 0.4 it is! “Requested ‘glib-2.0 >= 2.19.0’ but version of GLib is 2.18.4” RAAAH!@#(!@#%*(@#. ย (long live slackbuild, speeds things up a ton!)

Yeah, right now I’m getting pretty tired of gnome again… why was I building all this crap? And I’m not even halfway there. Probably a good thing to continue tomorrow on a fresh brain…. and I’ll be sure to take 3 year old versions then. Or maybe 1 year old, since the 3 year old garbage doesn’t build with recent compilers. *sigh* ๐Ÿ˜‰


Leave a Reply

You must be logged in to post a comment.


  • 2018 (1)
  • 2016 (1)
  • 2015 (7)
  • 2014 (4)
  • 2013 (11)
  • 2012 (27)
  • 2011 (26)
  • 2010 (25)
  • 2009 (68)